Skip to content

Commit

Permalink
[bot] AutoMerging: merge all upstream's changes:
Browse files Browse the repository at this point in the history
* https://github.com/coolsnowwolf/lede:
  rockchip: reorder r66s/p2 eth ports
  rockchip: add smp tune for fastrhino r66s
  kernel: bump 5.10 to 5.10.136
  kernel: bump 5.15 to 5.15.60
  ipq807x: add default packages about nss (coolsnowwolf#9920)
  arm-trusted-firmware-rockchip-vendor: rk3568 atf revert to v1.28
  rockchip: add kmod-ata-ahci-platform for Firefly Station P2
  kernel: bump 5.19 to 5.19.1
  rockchip: disable UHS modes for R66S
  rockchip: fix NanoPi R4S soft-reboot on some SD card
  rockchip: set initial signal voltage on power off
  mac80211: fix compile error (coolsnowwolf#9917)
  • Loading branch information
github-actions[bot] committed Aug 12, 2022
2 parents 3fce67a + 601c972 commit 9268465
Show file tree
Hide file tree
Showing 15 changed files with 122 additions and 54 deletions.
4 changes: 2 additions & 2 deletions include/kernel-5.10
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
LINUX_VERSION-5.10 = .135
LINUX_KERNEL_HASH-5.10.135 = e499a61be9ce670716dd27b5124bb9ef6c6bc0e8fab443abf717a77136543344
LINUX_VERSION-5.10 = .136
LINUX_KERNEL_HASH-5.10.136 = 1c099d0d59e7d9f671dfc947e16891b7a3a45efd7dfcc6b1e55a194961e45159
4 changes: 2 additions & 2 deletions include/kernel-5.15
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
LINUX_VERSION-5.15 = .59
LINUX_KERNEL_HASH-5.15.59 = e6ddc642057340db06b3b921c2b31bfed2c611359e8f144c3e5cf9c3ac33bccb
LINUX_VERSION-5.15 = .60
LINUX_KERNEL_HASH-5.15.60 = 2d9545f7c96faffd8407522011b9533adefd1360118494dfb6c862f2f15e237a
4 changes: 2 additions & 2 deletions include/kernel-5.19
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
LINUX_VERSION-5.19 =
LINUX_KERNEL_HASH-5.19 = ff240c579b9ee1affc318917de07394fc1c3bb49dac25ec1287370c2e15005a8
LINUX_VERSION-5.19 = .1
LINUX_KERNEL_HASH-5.19.1 = f4e27b926ea2c66b808db1f5706254cf92a8899e2108eedb0c3a7d12499aea55
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@ case "$VARIANT" in
LOADER="rk33/rk3399_miniloader_v1.26.bin"
;;
"rk3568")
ATF="rk35/rk3568_bl31_v1.34.elf"
ATF="rk35/rk3568_bl31_v1.28.elf"
DDR="rk35/rk3568_ddr_1560MHz_v1.13.bin"
;;
"rk3588")
Expand Down
Binary file not shown.
6 changes: 3 additions & 3 deletions package/boot/uboot-rockchip/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -133,7 +133,7 @@ define U-Boot/fastrhino-r66s-rk3568
fastrhino_r66s
DEPENDS:=+PACKAGE_u-boot-fastrhino-r66s-rk3568:arm-trusted-firmware-rk3568
PKG_BUILD_DEPENDS:=arm-trusted-firmware-rockchip-vendor
ATF:=rk3568_bl31_v1.34.elf
ATF:=rk3568_bl31_v1.28.elf
DDR:=rk3568_ddr_1560MHz_v1.13.bin
endef

Expand All @@ -144,7 +144,7 @@ define U-Boot/nanopi-r5s-rk3568
friendlyelec_nanopi-r5s
DEPENDS:=+PACKAGE_u-boot-nanopi-r5s-rk3568:arm-trusted-firmware-rk3568
PKG_BUILD_DEPENDS:=arm-trusted-firmware-rockchip-vendor
ATF:=rk3568_bl31_v1.34.elf
ATF:=rk3568_bl31_v1.28.elf
DDR:=rk3568_ddr_1560MHz_v1.13.bin
endef

Expand Down Expand Up @@ -175,7 +175,7 @@ define U-Boot/station-p2-rk3568
firefly_station-p2
DEPENDS:=+PACKAGE_u-boot-station-p2-rk3568:arm-trusted-firmware-rk3568
PKG_BUILD_DEPENDS:=arm-trusted-firmware-rockchip-vendor
ATF:=rk3568_bl31_v1.34.elf
ATF:=rk3568_bl31_v1.28.elf
DDR:=rk3568_ddr_1560MHz_v1.13.bin
endef

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -2,50 +2,58 @@ diff --git a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/core.c b/drivers/n
index 44a11b0..178e692 100644
--- a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/core.c
+++ b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/core.c
@@ -244,7 +244,7 @@ static int brcmf_netdev_set_mac_address(struct net_device *ndev, void *addr)
@@ -245,7 +245,11 @@
} else {
brcmf_dbg(TRACE, "updated to %pM\n", sa->sa_data);
memcpy(ifp->mac_addr, sa->sa_data, ETH_ALEN);
- memcpy(ifp->ndev->dev_addr, ifp->mac_addr, ETH_ALEN);
+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,18,0)
memcpy(ifp->ndev->dev_addr, ifp->mac_addr, ETH_ALEN);
+#else
+ eth_hw_addr_set(ifp->ndev, ifp->mac_addr);
+#endif
}
return err;
}
@@ -423,6 +423,7 @@ void brcmf_netif_rx(struct brcmf_if *ifp, struct sk_buff *skb, bool inirq)
@@ -424,6 +428,7 @@
ifp->ndev->stats.rx_packets++;

brcmf_dbg(DATA, "rx proto=0x%X\n", ntohs(skb->protocol));
+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,18,0)
if (inirq) {
netif_rx(skb);
} else {
@@ -432,6 +433,10 @@ void brcmf_netif_rx(struct brcmf_if *ifp, struct sk_buff *skb, bool inirq)
@@ -433,6 +438,9 @@
*/
netif_rx_ni(skb);
}
+#else
+ netif_rx(skb);
+#endif
+
}

void brcmf_netif_mon_rx(struct brcmf_if *ifp, struct sk_buff *skb)
@@ -672,7 +677,7 @@ int brcmf_net_attach(struct brcmf_if *ifp, bool locked)
@@ -673,7 +681,11 @@
ndev->ethtool_ops = &brcmf_ethtool_ops;

/* set the mac address & netns */
- memcpy(ndev->dev_addr, ifp->mac_addr, ETH_ALEN);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,18,0)
memcpy(ndev->dev_addr, ifp->mac_addr, ETH_ALEN);
+#else
+ eth_hw_addr_set(ifp->ndev, ifp->mac_addr);
+#endif
dev_net_set(ndev, wiphy_net(cfg_to_wiphy(drvr->config)));

INIT_WORK(&ifp->multicast_work, _brcmf_set_multicast_list);
@@ -847,7 +852,7 @@ static int brcmf_net_p2p_attach(struct brcmf_if *ifp)
@@ -848,7 +860,11 @@
ndev->netdev_ops = &brcmf_netdev_ops_p2p;

/* set the mac address */
- memcpy(ndev->dev_addr, ifp->mac_addr, ETH_ALEN);
+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,18,0)
memcpy(ndev->dev_addr, ifp->mac_addr, ETH_ALEN);
+#else
+ eth_hw_addr_set(ndev, ifp->mac_addr);

+#endif

if (register_netdev(ndev) != 0) {
bphy_err(drvr, "couldn't register the p2p net device\n");
diff --git a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/p2p.c b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/p2p.c
Expand Down Expand Up @@ -100,26 +108,35 @@ diff --git a/net/mac80211/iface.c b/net/mac80211/iface.c
index 57aa863..f5ebb5a 100644
--- a/net/mac80211/iface.c
+++ b/net/mac80211/iface.c
@@ -1272,9 +1272,7 @@ int ieee80211_do_open(struct wireless_dev *wdev, bool coming_up)
@@ -1274,9 +1274,13 @@
* this interface, if it has the special null one.
*/
if (dev && is_zero_ether_addr(dev->dev_addr)) {
- memcpy(dev->dev_addr,
- local->hw.wiphy->perm_addr,
- ETH_ALEN);
+ eth_hw_addr_set(dev, local->hw.wiphy->perm_addr);
+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,18,0)
memcpy(dev->dev_addr,
local->hw.wiphy->perm_addr,
ETH_ALEN);
+#else
+ eth_hw_addr_set(ndev, params->macaddr);
+#endif
memcpy(dev->perm_addr, dev->dev_addr, ETH_ALEN);

if (!is_valid_ether_addr(dev->dev_addr)) {
@@ -2134,9 +2132,9 @@ int ieee80211_if_add(struct ieee80211_local *local, const char *name,
@@ -2136,9 +2140,17 @@

ieee80211_assign_perm_addr(local, ndev->perm_addr, type);
if (is_valid_ether_addr(params->macaddr))
- memcpy(ndev->dev_addr, params->macaddr, ETH_ALEN);
+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,18,0)
memcpy(ndev->dev_addr, params->macaddr, ETH_ALEN);
+#else
+ eth_hw_addr_set(ndev, params->macaddr);
+#endif
else
- memcpy(ndev->dev_addr, ndev->perm_addr, ETH_ALEN);
+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,18,0)
memcpy(ndev->dev_addr, ndev->perm_addr, ETH_ALEN);
+#else
+ eth_hw_addr_set(ndev, ndev->perm_addr);
+#endif
SET_NETDEV_DEV(ndev, wiphy_dev(local->hw.wiphy));

/* don't use IEEE80211_DEV_TO_SUB_IF -- it checks too much */
1 change: 1 addition & 0 deletions target/linux/ipq807x/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -18,6 +18,7 @@ DEFAULT_PACKAGES += \
autocore-arm htop wpad-openssl zram-swap uboot-envtools \
kmod-qca-nss-dp kmod-qca-nss-drv-64 \
kmod-qca-nss-drv-pppoe-64 kmod-qca-nss-ecm-64 \
kmod-qca-nss-drv-bridge-mgr-64 kmod-qca-nss-drv-vlan-mgr-64 \
nss-firmware-ipq8074 luci-app-ipsec-vpnd \
luci-app-unblockmusic luci-app-zerotier

Expand Down
8 changes: 5 additions & 3 deletions target/linux/rockchip/armv8/base-files/etc/board.d/02_network
Original file line number Diff line number Diff line change
Expand Up @@ -10,17 +10,19 @@ rockchip_setup_interfaces()
case "$board" in
embedfire,doornet1|\
embedfire,doornet2|\
fastrhino,r66s|\
friendlyarm,nanopi-r2c|\
friendlyarm,nanopi-r2s|\
friendlyarm,nanopi-r4s|\
friendlyarm,nanopi-r4se|\
sharevdi,guangmiao-g4c|\
xunlong,orangepi-r1-plus|\
xunlong,orangepi-r1-plus-lts|\
firefly,rk3568-roc-pc)
xunlong,orangepi-r1-plus-lts)
ucidef_set_interfaces_lan_wan 'eth1' 'eth0'
;;
fastrhino,r66s|\
firefly,rk3568-roc-pc)
ucidef_set_interfaces_lan_wan "eth0" "eth1"
;;
friendlyelec,nanopi-r5s)
ucidef_set_interfaces_lan_wan "eth1 eth2" "eth0"
;;
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -43,6 +43,7 @@ sharevdi,guangmiao-g4c)
set_interface_core 10 "eth0"
set_interface_core 20 "eth1"
;;
fastrhino,r66s|\
firefly,rk3568-roc-pc)
set_interface_core 2 "eth0"
set_interface_core 4 "eth1"
Expand Down
13 changes: 0 additions & 13 deletions target/linux/rockchip/armv8/base-files/lib/preinit/04_reorder_eth

This file was deleted.

Original file line number Diff line number Diff line change
Expand Up @@ -472,7 +472,6 @@
cap-mmc-highspeed;
cap-sd-highspeed;
disable-wp;
sd-uhs-sdr104;
vmmc-supply = <&vcc3v3_sd>;
vqmmc-supply = <&vccio_sd>;
pinctrl-names = "default";
Expand Down
2 changes: 1 addition & 1 deletion target/linux/rockchip/image/armv8.mk
Original file line number Diff line number Diff line change
Expand Up @@ -138,6 +138,6 @@ define Device/firefly_station-p2
SOC := rk3568
UBOOT_DEVICE_NAME := station-p2-rk3568
IMAGE/sysupgrade.img.gz := boot-common | boot-script nanopi-r5s | pine64-img | gzip | append-metadata
DEVICE_PACKAGES := kmod-brcmfmac kmod-ikconfig station-p2-firmware wpad
DEVICE_PACKAGES := kmod-brcmfmac kmod-ikconfig ata-ahci-platform station-p2-firmware wpad
endef
TARGET_DEVICES += firefly_station-p2
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From 0d329112c709d6cfedf0fffb19f0cc6b19043f6b Mon Sep 17 00:00:00 2001
From: Jonas Karlman <[email protected]>
Date: Wed, 20 Feb 2019 07:38:34 +0000
Subject: [PATCH] mmc: core: set initial signal voltage on power off

Some boards have SD card connectors where the power rail cannot be switched
off by the driver. If the card has not been power cycled, it may still be
using 1.8V signaling after a warm re-boot. Bootroms expecting 3.3V signaling
will fail to boot from a UHS card that continue to use 1.8V signaling.

Set initial signal voltage in mmc_power_off() to allow re-boot to function.

This fixes re-boot with UHS cards on Asus Tinker Board (Rockchip RK3288),
same issue have been seen on some Rockchip RK3399 boards.

I am sending this as a RFC because I have no insights into SD/MMC subsystem,
this change fix a re-boot issue on my boards and does not break emmc/sdio.
Is this an acceptable workaround? Any advice is appreciated.

Signed-off-by: Jonas Karlman <[email protected]>
---
drivers/mmc/core/core.c | 2 ++
1 file changed, 2 insertions(+)

--- a/drivers/mmc/core/core.c
+++ b/drivers/mmc/core/core.c
@@ -1358,6 +1358,8 @@ void mmc_power_off(struct mmc_host *host

mmc_pwrseq_power_off(host);

+ mmc_set_initial_signal_voltage(host);
+
host->ios.clock = 0;
host->ios.vdd = 0;

Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
From: David Bauer <[email protected]>
Subject: arm64: dts: rockchip: disable UHS modes for NanoPi R4S

The NanoPi R4S leaves the SD card in 1.8V signalling when rebooting
while U-Boot requires the card to be in 3.3V mode.

Remove UHS support from the SD controller so the card remains in 3.3V
mode. This reduces transfer speeds but ensures a reboot whether from
userspace or following a kernel panic is always working.

Signed-off-by: David Bauer <[email protected]>

--- a/arch/arm64/boot/dts/rockchip/rk3399-nanopi-r4s.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3399-nanopi-r4s.dts
@@ -137,6 +137,11 @@
status = "disabled";
};

+&sdmmc {
+ /delete-property/ sd-uhs-sdr104;
+ cap-sd-highspeed;
+};
+
&u2phy0_host {
phy-supply = <&vdd_5v>;
};

0 comments on commit 9268465

Please sign in to comment.