forked from felixonmars/archriscv-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
This commit increases the SQLite operation timeout to 2.0 to make the test pass. Details see upstream: atuinsh/atuin#2337.
- Loading branch information
1 parent
01cb4a3
commit 36aa4bb
Showing
1 changed file
with
13 additions
and
5 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,19 @@ | ||
--- PKGBUILD | ||
+++ PKGBUILD | ||
@@ -32,7 +32,7 @@ build() { | ||
@@ -21,6 +21,8 @@ prepare() { | ||
cd "$pkgname-$pkgver" | ||
cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')" | ||
mkdir completions/ | ||
+ # increase SQLite connection timeout | ||
+ sed -i 's/Sqlite::new("sqlite::memory:", 0.1)/Sqlite::new("sqlite::memory:", 2.0)/' crates/atuin-client/src/database.rs | ||
} | ||
|
||
build() { | ||
@@ -36,6 +38,7 @@ build() { | ||
} | ||
|
||
check() { | ||
+ export ATUIN_TEST_SQLITE_STORE_TIMEOUT=2.0 | ||
cd "$pkgname-$pkgver" | ||
- cargo test --frozen --all-features --workspace --lib | ||
+ ATUIN_TEST_SQLITE_STORE_TIMEOUT=1.0 cargo test --frozen --all-features --workspace --lib | ||
cargo test --frozen --all-features --workspace --lib | ||
} | ||
|
||
package() { |